I create mousemade pixel perfection stuffs for the interwebs.

No Sense 3.0 for HTC Desire, Desire Z/G2, Desire HD, EVO 4G and Droid Incredible

Advertisement

HTC Sense 3.0

Advertisement

Developers! you are listening, right? HTC just over-relied on you guys to get the newly revealed HTC Sense 3.0 to the users of older HTC devices: Desire, Desire HD, G2/Desire Z, Droid Incredible, etc. The company’s twitter account replied to a query from a user about the Sense 3.0 on Desire HD, stating that “due to Sense’s hardware requirements, only our newest devices (Flyer, EVO 3D, Sensation) will be able to support it”. That’s a bit harsh to overlook the 1GHz phones just like that and underwhelming too, for something like Sense 3.0 when they’re quite upgradable to even Android 2.3 (and maybe newer android OS versions too!).

Anyway, the fav devs of yours got some working to do and we believe once the Sensation or any device with Sense 3.0 pre-installed gets released or the system dump is available, your HTC phone will get its share of Sense 3.0/x from the grey market. But that may require root access and stuff, which not all of you may be ready for, eh!

FYI, HTC’s latest version of its own UI, Sense 3.0 was revealed in the announcement event of its upcoming great device, HTC Sensation. Sense 3.0 packs in much improved 3D graphics, widget lock screen and other exciting stuff that every user of HTC’s 2010 devices would drool over.

Via UnwiredView

Published: 
Some HTML is OK
Join us on Facebook!schliessen
oeffnen