New Google Now Launcher APK for Android 4.2.2, 4.3 (Jelly Bean) and Above Devices. Version 1.0.9.1039417!

Only recently, Google launched its new Google Now Launcher into Play Store, but restricted it to Nexus and Nexus and Google Play Edition (GPE) devices only. Thus, leaving a majority of Android devices, running Android 4.2.2, 4.3 and 4.4 not eligible for the Now Launcher.

Well, worry no more, we’ve already got hands on the modified .APK file of the new Google Now Launcher, v1.0.9.1039417, which supports Android 4.2.2 and above Android device. Meaning your Jelly Bean device running Android 4.3/4.2.2 can now have the latest Google Now Launcher, with OK Google! working fine.

So, it should work fine on your Samsung Galaxy, Sony Xperia, HTC, LG and other Android device very well, if your device is running Android 4.2.2 or newer OS. Which includes Android 4.3 and 4.4 KitKat too!

Grab the .APK file of the modified Google Now Launcher from below and install it like any APK file. (Simply tap on it using a file manager app on your Android device to start manual installation, and be sure to enable Unknown Sources in Security settings.)

TIP: Be sure to uninstall any old Google Now Launcher that you may have. It will be appearing by name of Google Home or Launcher in your Manage Application list in Settings.

 icon-download DOWNLOAD MODIFIED GOOGLE NOW LAUNCHER APK (supports Android 4.2.2 and above)

Note: The translucent bar is available only on Android 4.4 KitKat and the API of Jelly Bean (Android 4.2 and Android 4.2) doesn’t support that.

If you need help with installing APK files on Android, follow the link below:

→ How to Install APK Files on Android

Btw, if you are looking for original un-modified APK file and link to Play Store, get that here.

Feedback Us!

Let us know how’s it working on your Android device.

Just make sure that your Android OS is Android 4.2.2 or above, and that you uninstalled the previous version of the Google Now Launcher, if you had any.

In case it didn’t work out, let us know your phone’s name (with OEM) and Android version.

18 Comment

  1. sepia66 says: Reply

    After installing the modified Google now it does not launch. Tells me I require the latest Google search from the play store. I already have the latest Google Search installed.

    1. Kapil says: Reply

      Will post you on this once new methods are found. For now, it seems we’re stuck with this problem. So, hang on for now.

  2. Tharaka Devinda says: Reply

    same here. Xperia V running v 4.3
    App installs with no issue. But it might be that the search version offered on google play for 4.4 is higher than the version offered for us. Anyway, I tried uninstalling search’s updates and re-installing the update after setting up launcher. Same effects.

    1. Kapil says: Reply

      Will post you on this once new methods are found. For now, it seems we’re stuck with this problem.

    2. I have a 4.4 Custom ROM, I pulled the latest Google Search version on it, and it’s the exact same version that’s available for Jelly Bean devices. Sideloading it made no difference. I think there’s something wrong with the mod for the Launcher itself.

  3. Wayne Tempel says: Reply

    The app installs fine, but it tells me that I need the latest version of Google Search in order to use the launcher. I have the latest version of search.

  4. roberthenderson says: Reply

    Ditto on the errant request to download the latest google search

  5. Oemus says: Reply

    seems to be the same for everyone, and we may need also a modified version of that google search update to make it work

  6. RJ21 says: Reply

    I have the same issue, asking to update google search but no update is available. But at the end of the day there isn’t much difference between this and the ripped apk from nexus 5 that we’ve had for ages.

  7. mike says: Reply

    I agree, i even uninstalled updates and reinstalled them to see if that works. no luck. Galaxy s3

  8. Ani Spoerlein says: Reply

    LG G Flex… Settings and everything done correctly. Still, when attempting to open the installed app it says there is a newer version of Google Search that must be installed. But there isn’t, it’s totally up-to-date.

    1. Same situation here on HTC One X (4.2.2). I have the latest Search app. It simply won’t run with the current version of the app.

    2. Same thing here… XPERIA Z (4.3)
      Funny thing – problem persists after second installation of this apk, as the first was 100% succesful and working.

  9. ashwin says: Reply

    Same for me also

  10. karthik says: Reply

    whem iam installing it it shows “download the new version”….im using xperia m…please modify the latest apk..

  11. anon says: Reply

    The link is offline

  12. joel huebner says: Reply

    I don’t think I’ll mess with it on my X-2, I bricked a cheepo tablet last week, 1’s enough.

  13. Jayprakash Kushwaha says: Reply

    सर,
    मुझे Jeally Bin version 4.2.2 का Google App चाहिये |
    plz help me sir!

Leave a Reply